以太网接口射频卡读卡器

02N 08N系列说明书

北京完美科学技术研究所

Web：www.iccard.cn

销售总机：010-63939086
地 址:100073 北京莲花池西里11号莲馨嘉园B座205


UDP协议的特点

(1) UDP是一个无连接协议，传输数据之前源端和终端不建立连接，当它想传送时就简单地去抓取来自应用程序的数据，并尽可能快地把它扔到网络上。在发送端，UDP传送数据的速度仅仅是受应用程序生成数据的速度、计算机的能力和传输带宽的限制；在接收端，UDP把每个消息段放在队列中，应用程序每次从队列中读一个消息段。

(2) 由于传输数据不建立连接，因此也就不需要维护连接状态，包括收发状态等，因此一台服务机可同时向多个客户机传输相同的消息。

(3) UDP信息包的标题很短，只有8个字节，相对于TCP的20个字节信息包的额外开销很小。

(4) 吞吐量不受拥挤控制算法的调节，只受应用软件生成数据的速率、传输带宽、源端和终端主机性能的限制。


读卡器介绍

一、功能

02N 08N系列读卡器用于多点读卡、集中读取控制的应用中，该读卡器采用以太网进行数据通讯，以太网具有传输距离远（可以全球互联）、传输速度高、实时性强（仅限于局域网）、可靠性高、后期工程维护工作量少等优点。传输层协议使用UDP，UDP有传输效率高，协议简单等特点。读卡器带有静电防护和短路保护能力 。

二、技术参数：

l 工作电源： +9V ~ +15V DC

l 额定电流： <200mA

l 输出： 红色LED指示、蜂鸣器

l 读卡器接口：以太网接口

l 工作环境： 温度-20℃~55℃，湿度0~90% 。

l 工作频率： 02N系列读卡器为125KHz，08N系列读卡器为13.56MHz

l 读卡类型： 02N系列读卡器为EM或与EM兼容的卡片, 08N系列读卡器为Mifare系列卡

l 感应距离： 6~10cm


接线端子说明

读卡器内部图：

锁与读卡器的连接:

1.电插锁与读卡器的连接

2.电磁锁与读卡器的连接


使用说明

读卡器外观：02NHKF读卡器外观如图1

图1

红色区域: 刷卡区和键盘输入

蓝色区域: 液晶显示区域

绿色区域：LED指示，其中上面的红色LED为受控LED,该LED的状态受读卡器配置和上位机应用软件的控制。下面的绿色LED为电源指示，读卡器接通电源时该LED点亮

读卡器内部：

图2

配置插针说明：插针插在下面的时候读卡器工作在配置模式（见上图），插针插在上面的时候读卡器工作在正常模式。模式改变后必须重新上电才有效。上电后读卡器滴滴响两声表示读卡器工作在正常模式。如果上电后大约5秒钟后读卡器长响一声表示读卡器工作在配置模式，同时外壳上的受控LED会长亮

读卡器在使用前需要进行配置,配置方法有两种:

方式一：配置模式配置（不需要知道读卡器的原配置，但需要打开读卡器后盖）；

方式二：正常模式配置（不需要打开读卡器后盖但需要知道读卡器原来的配置参数如读卡器IP、读卡器端口、服务器计算机IP服务器计算机端口，且需要把配置读卡器的计算机IP修改为读卡器参数中服务器计算机的IP）

读卡器的出厂为正常模式，初始设置为：

读卡器IP:192.168.0.101

子网掩码：255.255.255.0

默认网关：192.168.0.1

服务器IP:192.168.0.110

读卡器端口：1234

服务器端口：1234

具体配置过程见配置模式配置读卡器和正常模式配置读卡器

控制读卡器如下：

发送通讯测试数据（AA FF 01）如下：

Dim Senddata(2) As Byte

If SSock.State Then

SSock.Close

Else

SSock.RemoteHost = “192.168.0.12”

SSock.RemotePort = 1000

SSock.LocalPort = 1000

SSock.Bind 1000

SendData(0)=Val(“&HAA”)

SendData(1)=Val(“&HFF”)

SendData(2)=Val(“&H01”)

SSock.SendData Senddata

End If

接收数据如下：

Private Sub SSock_DataArrival(ByVal bytesTotal As Long)

Dim i As Integer

Dim StrData As String

Dim InData() As Byte

Dim datalen As Integer

SSock.GetData Indata

datalen = UBound(InData)

For i = 0 To datalen ‘把接收到的数据转换为十六进制

If InData(i) > 15 Then

StrData = StrData & " " & Hex(InData(i))

Else

StrData = StrData & " " & "0" & Hex(InData(i))

End If

Next i

SReceive.SelText = "接收 " & SSock.RemoteHostIP & ":" & StrData & Chr(13) & Chr(10)

End Sub


使用说明

配置模式配置读卡器

读卡器内部：

1. 连接好读卡器的网线，在读卡器断电时把配置插针插在上边两个针上，然后给读卡器上电，上电后大约5秒钟后读卡器长响一声表示读卡器工作在配置模式，同时外壳上的受控LED会长亮

2. 启动配置程序，刚启动程序界面如下：

修改读卡器配置参数下边的参数后，点“配置模式配置读卡器”按钮，如果配置成功界面如下：

3．配置成功后，断掉读卡器的电源，把配置插针插在下边两个针上，使读卡器处于正常模式，重新上电后读卡器就可以正常工作了

配置读卡器一些注意事项：

02N 08N系列读卡器支持自动极性转换，也就是说你可以把读卡器直接插在计算机的网卡上也可以插在交换机，路由器上进行配置。运行配置软件时如果有防火墙阻止，请解除防火墙阻止并重新运行配置软件


使用说明

正常模式配置读卡器

读卡器的出厂为正常模式，初始设置为

读卡器IP:192.168.0.101

子网掩码：255.255.255.0

默认网关：192.168.0.1

服务器IP:192.168.0.110

读卡器端口：1234

服务器端口：1234

连接好读卡器后，把当前要使用的计算机的IP修改为读卡器的配置的服务器计算机的IP,启动配置软件，如图下图

填写正常模式参数下的当前读卡器的IP、读卡器的端口、计算机的IP、计算机的端口,填写读卡器配置参数下的要配置的读卡器的参数，点“正常模式配置读卡器“按钮，显示配置成功提示框表明配置成功。

例如：要配置的读卡器当前参数如下

读卡器IP:192.168.0.101

服务器计算机IP:192.168.0.78

读卡器端口：1234

服务器计算机端口：1234

要把读卡器的配置修改为

读卡器IP:192.168.0.102

子网掩码：255.255.255.0

默认网关：192.168.0.1

服务器IP:192.168.0.77

读卡器端口：1234

服务器端口：1234

读卡时蜂蜜器发声

需要把正常模式参数框内的IP和端口号修改为上边读卡器的当前参数数值

填写读卡器配置参数框的参数，这个参数是把读卡器配置后的参数，也就是配置成功后读卡器的参数，须填写要把读卡器配置修改为的参数，点“正常模式配置读卡器“按钮，显示配置成功提示框表明配置成功。如下图

配置成功后，断掉读卡器的供电，重新上电后，读卡器就可以正常使用了

配置读卡器一些注意事项：

02N 08N系列读卡器支持自动极性转换，也就是说你可以把读卡器直接插在计算机的网卡上也可以插在交换机，路由器上进行配置。运行配置软件时如果有防火墙阻止，请解除防火墙阻止并重新运行配置软件


通讯测试

起始位 命令类型 命令参数

D1-D2 01 无

起始位：固定为AA FF

命令类型：必须为01

命令参数：无

命令长度：3

分机返回：BB FF FF 01 00 00 00

例如：

主机发送：AA FF 01

分机返回：BB FF FF 01 00 00 00


卡号上传

起始位 命令类型 命令参数

D1-D2 01 D4-D7

起始位： 固定为BB FF

命令类型：必须为01

命令参数：D4-D7,4个字节的卡号

例如：

返回卡号“01 02 03 04”

分机返回：BB FF 01 01 02 03 04


键盘按键

起始位 命令类型 命令参数

D1-D2 04 D4-D7

起始位：固定为BB FF

命令类型：必须为04

命令参数：D4为按键值 D5-D7全部为00

按键 | 0 | 1 | 2 | 3 | 4 | 5 | 6 | 7
按键值 | 0x00 | 0x01 | 0x02 | 0x03 | 0x04 | 0x05 | 0x06 | 0x07
按键 | 8 | 9 | . | F1 | F2 | 取消 | 确定
按键值 | 0x08 | 0x09 | 0x0A | 0x0B | 0x0C | 0x0D | 0x0E


开门按钮

起始位 命令类型 命令参数

D1-D2 02 D4-D7

起始位： 固定为BB FF

命令类型：必须为02

命令参数：D4-D8全部为00

例如：

分机返回：BB FF 02 00 00 00 00 00


门磁状态改变

起始位 命令类型 命令参数

D1-D2 03 D4-D7

起始位： 固定为BB FF

命令类型：必须为03

命令参数：D4为FF时门磁为高电平，D4为00时门磁为低电平 D5-D7全部为00

例如：

门磁为高电平

分机返回：BB FF 03 FF 00 00 00


蜂鸣器，LED,继电器控制

起始位 命令类型 命令参数

D1-D2 02 D4-D11

起始位： 固定为AA FF

命令类型：必须为02

命令长度：11

D4: LED点亮延时控制，为00时LED不点亮

D5: 蜂鸣器发声次数，为00时蜂鸣器不发声

D6: 蜂鸣器发声时间，为00时蜂鸣器不发声

D7: 蜂鸣器停止发声时间

D8:继电器1控制，为FF时继电器吸合，为00时继电器关闭，F0-FE之间的数值继

电器状态不变，01-EF之间的数值为继电器吸合的延时值

D9:继电器2控制，为FF时继电器吸合，为00时继电器关闭，F0-FE之间的数值继

电器状态不变，01-EF之间的数值为继电器吸合的延时值

D10:继电器3控制，为FF时继电器吸合，为00时继电器关闭，F0-FE之间的数值继

电器状态不变，01-EF之间的数值为继电器吸合的延时值

D11:继电器4控制，为FF时继电器吸合，为00时继电器关闭，F0-FE之间的数继

电器状态不变，01-EF之间的数值为继电器吸合的延时值

蜂鸣器，LED，继电器的时间基本单位为100毫秒

分机返回：

分机通信成功后返回： BB FF FF 02 00 00 00

分机命令执行中返回： BB FF FA 02 00 00 00

例如：

让读卡器LED点亮100毫秒，蜂鸣器发声两次，发声时间为200毫秒，发生间隔为300毫秒，继电器1的吸合时间为400毫秒，继电器2的吸合时间为500毫秒，继电器3的吸合时间为600毫秒，继电器4的吸合时间为700毫秒，应发送下列数据：

主机发送： AA FF 02 01 02 02 03 04 05 06 07

分机返回： BB FF FF 02 00 00 00

或者

BB FF FA 02 00 00 00

注意：没有用到的数据段一定要设为00，例如读卡器只有继电器1，那么继电器2，3，4一定要设为00，如果继电器1也没有的话那么也要设为00，以免影响延时参数


数码管显示

起始位 命令类型 命令参数

D1-D2 02 D4-D11

起始位： 固定为2个字节的AA FF

命令类型： 必须为04

D4-D11：可以显示数字，特殊符号，自定符号

命令长度： 11

返回命令

成功返回

BB FF FF 04

命令说明

上位机可以通过此命令来控制数码管上的显示内容，每个字节的8位对应关系见下图

数据位 | B7 | B6 | B5 | B4 | B3 | B2 | B1 | B0
数码管段 | DP | G | F | E | D | C | B | A

命令实例

显示下图的数字

应发送下列数据：

aa ff 04 06 5b 4f e6 5d 7d 07 7f

常见字符对应数值：

3F | 06 | 5B | 4F | 66 | 6D | 7D | 07
S5000774 | S5000775 | S5000776 | S5000777 | S5000780 | S5000781 | S5000782 | S5000783
7F | 6F | 00 | 40 | 39 | 73 | 79 | 71
S5000784 | S5000785 | S5000786 | S5000787 | S5000788 | S5000791 | S5000790 | S5000789


液晶显示

起始位 命令类型 命令参数

D1-D2 03 D4-D67

起始位 ：固定为AA FF

命令类型：必须为03

命令参数：D3-D67,要显示的字母、数字符号、中文字等的ANSI 字符代码 或Unicode 字符代码

命令长度：67

分机返回： BB FF FF 03 00 00 00

例如：

显示下图的字符

主机发送：

aa ff 03 d0 a1 d0 b4 d7 d6 c4 b8 3a 20 61 62 63 64 65 66 b4 f3 d0 b4 d7 d6 c4 b8 3a 20 41 42 43 44 45 46 20 20 20 20 ca fd d7 d6 3a 20 31 32 33 34 35 36 cc d8 ca e2 b7 fb ba c5 3a 20 21 22 23 24 25 26

其中红色部分为第1行显示的数据，棕色部分为第2行显示的数据，绿色部分为第3行显示的数据，蓝色部分为第4行显示的数据

分机通信成功后返回： BB FF FF 03 00 00 00

注意：

1． 如果所选用的读卡器时两行的液晶屏的话，那么第3行和第4行的数据可以为任意值因为液晶只有两行所以第3和第4行的数据不会显示出来

2． 总共提供8192个中文字型128个符号字型，可以显示字母、数字符号、中文字型


语音命令

起始位 命令类型 命令参数

D1-D2 05 D4-Dx

起始位：固定为AA FF

命令类型：必须为05

命令参数：D4为语音的长度

D5-Dx为语音内容，要语音的汉字、数字等的ANSI 字符代码 或Unicode 字符代码

命令长度：未知

分机返回：

通信成功后返回 ： BB FF FF 05 FF 00 00

命令长度错误返回：BB FF FA 05 00 00 00

语音执行完返回： BB FF FF 05 00 00 00

例如：

要发送“你好”的语音

主机发送： AA FF 05 04 C4 FA BA C3 （其中红色字体部分是“你好”的编码 ）

分机返回 ： BB FF FA 05 00 00 00

或者

BB FF FF 05 FF 00 00

或者

BB FF FF 05 00 00 00


配置读卡器

配置读卡器命令：

参数说明 | 起始位 | 读卡器型号 | 本机IP | 子网掩码
数据长度 | 4 | 1 | 4 | 4
参数说明 | 默认网关 | 目标主机IP | 本机端口 | 目标端口
数据长度 | 4 | 4 | 2 | 2
参数说明 | 本机MAC | 蜂鸣器设置 | 结束位
数据长度 | 6 | 1 | 4

起始位： 固定为E0 E0 E0 E0

读卡器型号： 保留位，暂时无用

蜂鸣器设置： FF：刷卡时蜂鸣器发声 00刷卡时蜂鸣器不发声 其他值无效

结束位： 固定为0E 0E 0E 0E

命令说明：此命令长度位36个字节，起始位为第一个字节，结束位为最后一个字节。命令发出后若配置成功，02N 08N系列读卡器会返回所发送的数据

读取读卡器配置命令：

E6 E3 E9 E3 E9 E0 E8 E6

命令说明：此命令用于使02N 08N系列读卡器返回配置信息，返回的信息格式为“配置命令”的通讯格式

发送方式：

1．配置模式时

配置命令和读取配置命令都通过广播地址发送，读卡器和计算机端口都用1000

2．正常模式时

配置命令和读取配置命令都通过指定IP和端口发送（读卡器当前的IP和接收命令的端口），服务器计算机把要发送的命令通过指定IP发送给要配置或读取配置的读卡器，读卡器把执行结果发送给服务器计算机


02N 08N系列读卡器区别

02N系列读卡器识别的是EMID卡

08N系列读卡器识别的是Mifare系列卡


02N系列读卡器列表

 | 液晶屏（H） | 键盘（K） | 数码管（L） | 继电器（F） | 语音（Y）
02NA |  |  |  |  |
02NH | √ |  |  |  |
02NL |  |  | √ |  |
02NF |  |  |  | √ |
02NY |  |  |  |  | √
02NHK | √ | √ |  |  |
02NHF | √ |  |  | √ |
02NHY | √ |  |  |  | √
02NLF |  |  | √ | √ |
02NFY |  |  |  | √ | √
02NHKF | √ | √ |  | √ |
02NHKY | √ | √ |  |  | √
02NHLF | √ |  | √ | √ |
02NHFY | √ |  |  | √ | √
02NKLY |  | √ | √ |  | √
02NKFY |  | √ |  | √ | √
02NHKLFY | √ | √ | √ | √ | √

08N系列读卡器列表

 | 液晶屏（H） | 键盘（K） | 数码管（L） | 继电器（F） | 语音（Y）
08NA |  |  |  |  |
08NH | √ |  |  |  |
08NL |  |  | √ |  |
08NF |  |  |  | √ |
08NY |  |  |  |  | √
08NHK | √ | √ |  |  |
08NHF | √ |  |  | √ |
08NHY | √ |  |  |  | √
08NLF |  |  | √ | √ |
08NFY |  |  |  | √ | √
08NHKF | √ | √ |  | √ |
08NHKY | √ | √ |  |  | √
08NHLF | √ |  | √ | √ |
08NHFY | √ |  |  | √ | √
08NKLY |  | √ | √ |  | √
08NKFY |  | √ |  | √ | √
08NHKLFY | √ | √ | √ | √ | √


Easy CHM - http://www.eTextWizard.com

您现在使用的CHM文件由Easy CHM的未注册版本制作.
注册版本不会在CHM里自动添加此页面

Easy CHM 软件 软件出品: 国华软件 中国北京 |  | 截屏图片
 | 文件大小: 2989k - 2.84MB | 软件类型: 共享软件 购买注册: 这里
关键词: make chm, create chm, chm制作工具, chm电子书制作工具,chm帮助文件制作工具

描述:

Easy CHM是国华软件推出的一款强大的CHM电子书或CHM帮助文件的快速制作工具。使用EasyCHM只需要三个步骤就可以完成CHM的制作：1、用户指定一个目录，EasyCHM会自动导入全部目录及文件；2、设置CHM编译选项；3、开始制作。EasyCHM非常适合个人和单位制作高压缩比的带有全文检索及高亮显示搜索结果的网页集锦、CHM帮助文件、产品说明、公司介绍、CHM电子书等等。

主要功能：

  • 全自动的目录及文件导入（可以包括子目录）；
  • EasyCHM支持导入任意的文件类型；
  • EasyCHM操作速度快，性能稳定，EasyCHM因为上手容易深得广大用户好评；
  • EasyCHM自动生成CHM的目录列表并自动生成所有目录项；
  • 为CHM的目录列表自动添加多级编号；
  • 在编辑目录项、索引项时用到的移动、拖拽、替换等操作中Easy CHM完全支持多选操作，避免了一项一项地操作，极大的减少用户手工 － 非常适合企业维护CHM帮助文档；
  • 支持批量查找替换多级目录各项的标题文字内容；
  • 允许用户指定从文本文件的第N行自动截取标题；
  • 易用的目录编辑器；
  • 丰富实用的CHM制作选项帮助用户制作更加个性化的专业CHM电子书或CHM帮助文件；
  • EasyCHM自动生成输出Alias和Map头文件；
  • EasyCHM自动生成上下文相关的帮助文件（ContextID），适合于制作专业的支持Help Context ID的专业帮助文件；
  • EasyCHM可以保存工程文件，方便企业用户编辑维护文档。
  • 批量更换CHM目录各项的图标；
  • 内嵌CHM反编译工具；

EasyCHM未注册版本的主要限制：

  1. EasyCHM的未注册版本可以制作带任意层级目录的CHM，但是每个CHM的工具栏上都会自动添加一个ABOUT按钮，以提醒用户注册。注册版本不会添加ABOUT按钮。
  2. EasyCHM的未注册版本无法保存CHM的通用工程文件，如*.HHP、*.HHC、*.HHK等，未注册版本的EasyCHM会自动删除*.HHP、*.HHC、*.HHK这几个文件。

注册版本无任何限制。
如果EasyCHM可以为您的工作和学习提供帮助，请注册购买，感谢您给予软件作者的支持。
联系方式:
国华软件站点一: http://www.etextwizard.com
国华软件站点二: http://www.zipghost.com
技术支持信箱: webmaster@etextwizard.com
购买方式:
在线购买:（可提供发票，支持很多种支付方式，包括邮政汇款）
单用户企业版 299元 人民币 ：通过“共享软件注册中心”购买

单用户家庭版 99元 人民币： 通过“共享软件注册中心”购买
直接向作者注册（共3种方式）：
1、招商银行划款:
开户行： 招商银行北京分行双榆树支行
帐 号： 001015570093
户 名： 冯国华
2、中国农业银行金穗卡转帐（注意是卡号）：
金穗卡卡号： 95599 8001 42061 34216
收 款 人： 冯国华
3、中国工商银行牡丹灵通卡转帐：

开户城市：北京
牡丹灵通卡卡号：9558 8202 0000 3186295 （注意是卡号9558820200003186295）
收 款 人： 冯国华

注意事项：
直接向作者注册的用户请在汇出足额的注册费后以EMAIL形式通知作者，同时请尽量提供

  • 汇款日期

  • 汇出城市

  • 您汇到作者哪个帐号？

  • 汇款人姓名

  • 用于接收注册码的信箱（请确保可以接收邮件，最好多提供）

  • 您希望的注册用户名

  • 要注册的软件及套数

您提供的资料详细些会比较方便确认。
作者在确认支付已完成后将会马上发出注册码。
用户在收到注册信后请尽量给软件作者发个类似“已收到注册码”的确认信 - 感谢您的配合！
下载地址:

系统需求: Win98,WinME,WinXP,Windows2000,WinVista
安装支持: 支持安装及卸载