125Khz射频卡读卡器

02CHK 说明书

北京完美科学技术研究所

Web：www.iccard.cn

销售总机：010-63939086
地 址:100073 北京莲花池西里11号莲馨嘉园B座205


一、概述：

读卡器介绍

一、概述：

WM-02CHK读卡器主要应用于多点读卡、集中读取控制的应用中，该读卡器采用CAN总线进行数据通讯，该总线具有传输距离远、传输速度快、类似局域网的冲突处理、实时性强、可靠性高、后期工程维护工作量少等优点，由于采用短帧结构使得该总线具有较高的可靠性和实时性，是目前替代485总线的最佳选择，本读卡器带有静电防护和短路保护能力，接口线只有4根，连线简单，通讯距离最远可达10公里（波特率为 4800），通信波特率最高可达230400（通讯距离小于270米），最大限度满足大型工程安装布线的需要，读卡器与计算机通讯选用本公司自主开发的“USB-CAN”转换器，不支持与其他CAN设备之间的通讯（如CAN卡）。

二、技术参数：

l 工作电源：+9V ~ +15V DC

l 额定电流：<200mA

l 输出：红色LED指示、蜂鸣器（通过插针可以选择不同的模式，详见下）

l 读卡器接口：CAN接口

l 总线波特率：4800、9600、19200、57600、115200、230400

l 工作环境：温度-20℃~55℃，湿度0~90% 。

l 工作频率：125KHz

l 读卡类型：EM或与EM兼容的卡片

l 感应距离：6~10cm

l 接口接线方式：内部端子

表1

位速率/kbps | 230400 | 115200 | 57600 | 19200 | 9600 | 4800
最大距离/m | 270 | 620 | 1000 | 3300 | 6700 | 10000

实物图片：

外观图

受控LED: 该LED可以通过用户软件点亮或熄灭。

状态指示: 该LED用于指示读卡器的通讯状态，上电后该LED点亮表示读卡器工作正常，如果在通讯的过程中该LED熄灭，则表示通讯发生了错误，通讯正常后该LED会自动点亮。

液晶屏: 该液晶屏最多可以显示16个汉字和32个英文字母（包括特殊符号），也可以同时显示英文字母和汉字。

显示英文字母和特殊符号 显示汉字 汉字和英文字母同时显示

内部图


读卡器的安装

内部图

首先把读卡器和USB-CAN转换器连接起来，把转换器和读卡器的波特率设置成一致的，然后把USB-CAN的USB线插入计算机的USB端口，然后向USB-CAN转换器生成的串口号发送命令即可。USB-CAN转换器的使用方法请参阅用户光盘中的“USB-CAN转换器使用说明”。 图4是USB-CAN和02CHK读卡器连接的参照图。

图4

以上图片仅供参考，实际应用中每两个相邻读卡器的距离必须大于20cm，否则会相互干扰。

建议采用屏蔽双绞线布线，所有CAN线必须用一种线，以免在两种线的接点处产生信号碰撞，如果电源采用总线方式供电，电源线不能在数据线的屏蔽层内，并且要选择比较好的电源, 在最远处的读卡器应加装终端电阻，阻值为120欧。

如果没有CAN总线布线经验，请在施工买料之前咨询我单位技术人员。


地址设定

内部图

地址设定：用户可以通过这些插针设定读卡器的地址，用户必须保证所设定的地址在所在网络上是唯一的，否则读卡器将不能正常工作。读卡器的地址不能为0，也就是说插针是不能全部断开的（图1）。计算地址值有两种表示方法：一是采用“16进制”的方法表示，八个插针正好是一个字节。例如地址为“0x12”的插针设置如图2；二是将插有插针的旁边的数字加起来就是十进制的地址，例如地址为18的插针设置如图2。

图1 图2


蜂鸣器设定

蜂鸣器设定：蜂鸣器可以通过这个插针选择不同的发声方式，当拔掉插针时读卡器一旦检测到卡就会发声，（程序也能再控制发声）；当插上插针时，即便检测到卡读卡器也不会发声，这时用户可以通过程序来控制发声。

内部图


波特率设定

内部图

波特率设定：通过这些插针的设定，用户可以使读卡器工作在不同的波特率，通讯距离越远，波特率越低。波特率越高，通讯距离越近。具体距离和波特率的对照关系请参照“读卡器介绍中的表1”

具体的波特率设定请参照以下图片

4800 9600 19200

57600 115200 230400


数据格式

以下是02CHK读卡器的命令格式长度采用固定的13个字节。以下是具体每个字节的详细说明。

D1 D2 D3 D4 D5 D6 D7 D8 D9 D10 D11 D12 D13

D1: 数据起始位

D2: FF

D3: 读卡器地址

D4: 数据长度

D5: 命令类型

D6: 数据

D7: 数据

D8: 数据

D9: 数据

D10: 数据

D11: 数据

D12: 数据

D13: D1-12的异或结果

1：数据起始位有D1和D2两位组成，主机发送数据时为：AA FF

读卡器返回数据时为：BB FF

2: 读卡器地址为要控制的读卡器地址，每个读卡器的地址是唯一的，00H是读卡器的广播地址

3：数据长度是从D4以后的有效数据长度，该值最大为 08H

4：命令类型是主机或读卡器将要执行的不同操作

5：D13是校验位，如果D1-D12的异或结果等于D13则表示数据在传输中没有发生错误，如不相等必须丢弃该数据


发光管（外壳上的受控LED），蜂鸣器控制

D1 | D2 | D3 | D4 | D5 | D6 | D7 | D8 | D9 | D10 | D11 | D12 | D13
AA | FF | SS | 08 | 01 | SS | SS | SS | SS | SS | 00 | 00 | ZZ

XX: 表示任意值

SS: 与该命令相关的数据

ZZ: 校验和

D3: 读卡器地址

D4: 数据长度，该位必须为 08

D5: 该命令的标志位，该位必须为 01

D6: 发光管控制 00：发光管熄灭 FF： 发光管点亮 其他值发光管的状态不变

D7: 延时时间：该位为 “00”将忽略该位的值。如果D6为 “ FF”该值为发光管点亮维持的时间。

如果D6为 “ 00”该值为发光管熄灭维持的时间。

D8: 蜂鸣器的发声次数 ，该位为 “00” 时蜂鸣器不发声

D9: 蜂鸣器的发声时间 ，该位为 “00” 时蜂鸣器不发声

D10: 蜂鸣器的发声间隔 ，该位为 “00” 时蜂鸣器没有间隔

D11: 该位必须为 00

D12 : 该位必须为 00

注意：发光管的延时时间，蜂鸣器的发声时间，蜂鸣器的发声间隔时间均以0.1秒为单位。


液晶显示命令 （计算机发送）

D1 | D2 | D3 | D4 | D5 | D6 | D7 | D8 | D9 | D10 | D11 | D12 | D13
AA | FF | SS | SS | 02 | SS | SS | SS | SS | SS | SS | SS | ZZ

XX: 表示任意值

SS: 与该命令相关的数据

ZZ: 校验和

D3: 读卡器地址

D4: 数据长度，00-08

D5: 该命令的标志位，该位必须为 02

D6: 00-05为更新显示缓冲区的命令，06-09为液晶屏的控制命令。下图中红色的阴影部分为不同数值对应的字符位置，显示的数据可以是汉字也可以是英文或特殊字符，一个汉字等于2个英文字母或特殊字符的位置。显示汉字起始位置必须是奇数。

00 [image] 数据长度为“08”

01 [image] 数据长度为“08”

02 [image] 数据长度为“08”

03 [image] 数据长度为“08”

04 [image] 数据长度为“08”

05 [image] 数据长度为“04”

06 显示数据 数据长度为“02”

07 清除显示缓冲区数据，同时清屏 数据长度为“02”

08 清除显示缓冲区 数据长度为“02”

09 清屏 数据长度为“02”

D7 D8, D9 D10 , D11,D12 为将要显示的数据编码，不显示的位应为“20”

上图的上下两行显示的汉字编码是一样的，但是因为上行的汉字的起始位置是从偶数开始的，所以显示出来的汉字是错误的。

例如：要在地址为“01”的读卡器的液晶屏上第4个位置显示“请”，第5个位置显示“刷”，第6个位置显示“卡”，则应按下列步骤发送数据

1：清除显示

D1 | D2 | D3 | D4 | D5 | D6 | D7 | D8 | D9 | D10 | D11 | D12 | D13
AA | FF | 01 | 02 | 02 | 07 | XX | XX | XX | XX | XX | XX | ZZ

2：发送要显示的数据

D1 | D2 | D3 | D4 | D5 | D6 | D7 | D8 | D9 | D10 | D11 | D12 | D13
AA | FF | 01 | 08 | 02 | 01 | C7 | EB | CB | A2 | BF | A8 | ZZ

其中 “C7 EB” 是“请”的编码 ，“CB A2” 是“刷”的编码 ，“BF A8” 是“卡”的编码

3：显示发送的数据

D1 | D2 | D3 | D4 | D5 | D6 | D7 | D8 | D9 | D10 | D11 | D12 | D13
AA | FF | 01 | 02 | 02 | 06 | XX | XX | XX | XX | XX | XX | ZZ


键盘数据

D1 | D2 | D3 | D4 | D5 | D6 | D7 | D8 | D9 | D10 | D11 | D12 | D13
BB | FF | SS | 02 | 05 | SS | XX | XX | XX | XX | XX | XX | ZZ

XX: 表示任意值

SS: 与该命令相关的数据

ZZ: 校验和

D3: 读卡器地址

D4: 数据长度: 02

D5: 该命令的标志位，该位必须为 05

D6: 读卡器返回的键盘数据 ,数值采用16进制表示。具体数值见下表

按键 | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 0 | . | 确定 | 取消 | F1 | F2
数值 | 01 | 02 | 03 | 04 | 05 | 06 | 07 | 08 | 09 | 0A | 0B | 0C | 0D | 0E | 0F


测试读卡器是否存在

D1 | D2 | D3 | D4 | D5 | D6 | D7 | D8 | D9 | D10 | D11 | D12 | D13
AA | FF | SS | 01 | 09 | XX | XX | XX | XX | XX | XX | XX | ZZ

XX: 表示任意值

SS: 与该命令相关的数据

ZZ: 校验和

D3: 读卡器地址

D4: 数据长度,该位必须为01

D5: 该命令的标志位，该位必须为 09

该命令用于确定该地址的读卡器是否存在，读卡器收到此命令后会返回“返回读卡器命令”，否则表示该地址的读卡器不存在。

例如：要检测地址为01的读卡器是否存在，则要发送以下数据

D1 | D2 | D3 | D4 | D5 | D6 | D7 | D8 | D9 | D10 | D11 | D12 | D13
AA | FF | 01 | 01 | 09 | XX | XX | XX | XX | XX | XX | XX | ZZ

如果该地址的读卡器存在，就会返回以下数据

D1 | D2 | D3 | D4 | D5 | D6 | D7 | D8 | D9 | D10 | D11 | D12 | D13
BB | FF | 01 | 01 | 08 | XX | XX | XX | XX | XX | XX | XX | ZZ

如果在300毫秒之内没有返回任何数据，则表示该地址的读卡器不存在

读卡器返回存在命令

D1 | D2 | D3 | D4 | D5 | D6 | D7 | D8 | D9 | D10 | D11 | D12 | D13
BB | FF | SS | 01 | 08 | XX | XX | XX | XX | XX | XX | XX | ZZ

XX: 表示任意值

SS: 与该命令相关的数据

ZZ: 校验和

D1: BB

D3: 读卡器地址

D4: 数据长度，该位必须为01

D5: 该命令的标志位，该位必须为 08

读卡器在收到“检测读卡器是否存在”命令后,返回此条命令，用于告知主机该地址的读卡器是存在的


读卡器发送卡号命令

D1 | D2 | D3 | D4 | D5 | D6 | D7 | D8 | D9 | D10 | D11 | D12 | D13
BB | FF | SS | 05 | 06 | SS | SS | SS | SS | XX | XX | XX | ZZ

XX: 表示任意值

SS: 与该命令相关的数据

ZZ: 校验和

D3: 读卡器地址

D4: 数据长度: 05

D5: 该命令的标志位，该位必须为 06

D6, D7,D8,D9 为卡号

注意：一旦读卡器检测到EM卡后，就会把此命令发送给计算机

例如：地址为01的读卡器检测到卡号为 01 02 03 04 的卡后，就会向计算机发送以下数据

D1 | D2 | D3 | D4 | D5 | D6 | D7 | D8 | D9 | D10 | D11 | D12 | D13
BB | FF | 01 | 05 | 06 | 01 | 02 | 03 | 04 | XX | XX | XX | ZZ


USB-CAN转换器状态 （USB-CAN转换器返回）

D1 | D2 | D3 | D4 | D5 | D6 | D7 | D8 | D9 | D10 | D11 | D12 | D13
BB | FF | 00 | 02 | 0A | AA | XX | XX | XX | XX | XX | XX | ZZ

XX: 表示任意值

ZZ: 校验和

D3: 转换器的地址,该位必须是00

D4: 数据长度，该位必须为02

D5: 该命令的标志位，该位必须为 0A

D6: 必须是AA

计算机发出任何命令后，必须等待USB-CAN转换器返回此条命令，才可以继续发送数据。如果超过300毫秒仍没有返回此条命令，将由计算机决定是否重发。


1

1．02CHK简介

02CHKLF读卡器主要应用于多点读卡、集中读取控制的应用中。该读卡器采用CAN总线进行数据通讯，实时性强。

2．编程说明

由于读卡器可以实时的向主机返回人员的刷卡情况，所以只要实时记录每台读卡器返回的数据就可以做出适合自己的软件。

3．注意

在向读卡器发出一条命令后需等待USB-CAN转换器返回(USB-CAN转换器状态)命令后再读卡器发送下一条命令，如果在发出命令300毫秒后还没有(USB-CAN转换器状态)命令的返回就需要重新发送此命令。


Easy CHM - http://www.eTextWizard.com

您现在使用的CHM文件由Easy CHM的未注册版本制作.
注册版本不会在CHM里自动添加此页面

Easy CHM 软件 软件出品: 国华软件 中国北京 |  | 截屏图片
 | 文件大小: 1392k - 1.39MB | 软件类型: 共享软件 购买注册: 这里
关键词: make chm, create chm, chm制作工具, chm电子书制作工具,chm帮助文件制作工具

描述:

Easy CHM是国华软件推出的一款强大的CHM电子书或CHM帮助文件的快速制作工具。使用EasyCHM只需要三个步骤就可以完成CHM的制作：1、用户指定一个目录，EasyCHM会自动导入全部目录及文件；2、设置CHM编译选项；3、开始制作。EasyCHM非常适合个人和单位制作高压缩比的带有全文检索及高亮显示搜索结果的网页集锦、CHM帮助文件、产品说明、公司介绍、CHM电子书等等。

主要功能：

  • 全自动的目录及文件导入（可以包括子目录）；
  • 自动生成上下文相关的帮助文件直接供程序员使用；
  • 支持导入任意的文件类型；
  • 自动生成CHM的目录列表并自动生成所有目录项；
  • 为CHM的目录列表自动添加多级编号；
  • 批量更换CHM目录各项的图标；
  • 支持批量查找替换多级目录各项的标题文字内容；
  • 允许用户指定从文本文件的第N行自动截取标题；
  • 易用的目录编辑器；
  • 丰富实用的CHM制作选项帮助用户制作更加个性化的专业CHM电子书或CHM帮助文件。
  • 内嵌CHM反编译工具。
  • 用户可以保存和打开工程文件。

EasyCHM未注册版本的主要限制：

  1. EasyCHM的未注册版本可以制作带任意层级目录的CHM，但是每个CHM的工具栏上都会自动添加一个ABOUT按钮，以提醒用户注册。注册版本不会添加ABOUT按钮。
  2. EasyCHM的未注册版本无法保存CHM的通用工程文件，如*.HHP、*.HHC、*.HHK等，未注册版本的EasyCHM会自动删除*.HHP、*.HHC、*.HHK这几个文件。

注册版本无任何限制。
如果EasyCHM可以为您的工作和学习提供帮助，请注册购买，感谢您给予软件作者的支持。
联系方式:
国华软件站点一: http://www.etextwizard.com
国华软件站点二: http://www.zipghost.com
技术支持信箱: webmaster@etextwizard.com
购买方式:
在线购买:（可提供发票，支持很多种支付方式，包括邮政汇款）
单用户企业版 299元 人民币 ：通过“共享软件注册中心”购买

单用户家庭版 99元 人民币： 通过“共享软件注册中心”购买
直接向作者注册（共3种方式）：
1、招商银行划款:
开户行： 招商银行北京分行双榆树支行
帐 号： 001015570093
户 名： 冯国华
2、中国农业银行金穗卡转帐（注意是卡号）：
金穗卡卡号： 95599 8001 42061 34216
收 款 人： 冯国华
3、中国工商银行牡丹灵通卡转帐：

开户城市：北京
牡丹灵通卡卡号：9558 8202 0000 3186295 （注意是卡号9558820200003186295）
收 款 人： 冯国华

注意事项：
直接向作者注册的用户请在汇出足额的注册费后以EMAIL形式通知作者，同时请尽量提供

  • 汇款日期

  • 汇出城市

  • 汇出行

  • 汇款人姓名

  • 用于接收注册码的信箱（请确保可以接收邮件，最好多提供）

  • 您希望的注册用户名

  • 要注册的软件及套数

您提供的资料详细些会比较方便确认。
作者在确认支付已完成后将会马上发出注册码。
用户在收到注册信后请尽量给软件作者发个类似“已收到注册码”的确认信 - 感谢您的配合！
下载地址:

系统需求: Win98,WinME,WinXP,Windows2000
安装支持: 支持安装及卸载